Home Faculty Lab Media Resource
Center
Staff Lab Student Technology
Education Lab
Our Staff

Paint Shop Pro
Opening Existing Image Files
Creating New Image Files
Using the Browser
Saving and Reformatting Image Files
Color Functions
Basic Image Editing
Using Selection Tools
Painting and Drawing
Layers
Tips:Changing Backgrounds to Transparent

Paint Shop Pro is a painting program used to edit existing image files, to create new images, and to browse collections of images.

Use artistic painting and drawing tools in Paint Shop Pro to create various images, and Web development futures to enhance the appearance of your Web pages.

Paint Shop Pro creates images in almost thirty different types of graphic formats including the .BMP format, the .JPG format, and the .GIF format.

Opening Existing Image Files


Choose Open from the File menu and click on the file to work on in Paint Shop Pro. A list of recently used files appears at the bottom of the file menu which can also be used to access a file. The graphic appears in its own window in the workspace. Multiple files can be opened in Paint Shop Pro as memory allows.

Creating New Image Files

Select New from the File menu. Use the Width and Height spin controls to set the image's dimensions in pixels. Select a new color from the Background Color drop down menu to fill the new image. The first two choices are the current active colors on the Color Palette. The image type is the new image's color depth. Select the image type from the Image Type drop down menu. At the bottom of the NewImage dialog box is a text display that indicates how much memory (RAM) is required to create the new image. If you don't have at least as much memory as is indicated here, select one or both of the following: lower color depth or smaller dimensions. Click OK.

Using the Browser

Use the browser to scan through a collection of images in a folder. Images are displayed as small, thumbnail graphics that link access to the source file.

From the File menu, choose Browse and select a folder. If there are image files in the selected folder, thumbnails will fill the window.

Use thumbnails to manage source graphic files.
To open a single file, double-click the picture on the thumbnail or select the picture and then click the right button of the mouse, then select Open from the pop-up menu. To open multiple files, hold down "Ctrl" key and select the files that you want to open and then select Open from the ImageFile menu. Sort, Select, Update or Print thumbnails from the File menu. Choose Copy to, Move to, Rename, or Delete from the ImageFile menu.

 

Saving and Reformatting Image Files

To save the changes to the active image, select Save from the File menu or click on the Save button in the toolbar. If you are saving a new file, Paint Shop Pro will open the Save As dialogue box. Select a folder using the Save In drop down box or click on the Create New Folder button. Select the file type from the File Type drop down box. Enter a name for the new file in the File Name text box. Paint Shop Pro will automatically add the file extension. Click on the Save button.
To copy a file to a different file format, select Save As from the File menu. Paint Shop Pro will open the Save As dialog box. Use the dialog box to save the image under a new filename and choose a new file type from the File Type drop down box.

 

Color Functions

Choosing Colors Changing Number of Colors Brightness / Contrast Hue / Saturation/Luminance Grey Scale Function

Choosing Colors

Pointthe cursor at the Select Color panel. The cursor will change into an eyedropper. Click the eyedropper on the color that you want to select with the primary mouse button(Left) to select the foreground color and the secondary mouse button(Right) to select the background color.

Sample: Eyedropper is over the yellow color. By clicking the left mouse button, the green will be replaced with yellow. By clicking with right mouse button, the dark yellow will be replaced by yellow.

To select an active color from the active image's available color, click on the foreground color or the background color in the Color Styles Panel. The Active Colors Panel appears in the Color Style Palette. Be sure to choose colors before choosing a tool. Then choose Solid style in Active Color Style Panel. Painting with the primary(Left) mouse button applies foreground color. The secondary mouse button (Right) applies background color.

Sample: Foreground is Green and background is dark yellow. Clicking on the two-headed arrow will reverse the foreground and background colors.

Changing Number of Colors

To find out how many colors are used in the active image, select Count Colors Used from the Colors menu. To increase the number of available colors in the active image, select Increase Color Depth from the Colors menu. Select the color depth that you want to use. To decrease the number of available colors, select Decrease Color Depth from the Colors menu. However, decreasing depth can harm or even ruin an image's composition.

Original with 16 million colors:


Reduced to 256 colors:

Reduced to 16 colors:
Brightness / Contrast

Brightness shifts the entire histogram, and Contrast stretches or compresses it. Select Adjust->Brightness and Contrast from the Colors menu. A thumbnail of the original image is shown on the left and a preview of the changes is shown on the right.

Samples of Increasing and Decreasing Contrast:

Samples of Increasing and Decreasing Brightness:

Hue / Saturation/Luminance

Hue describes the color's shade or tint, saturation describes the hue's purity, and luminance describes the color's. Select Adjust->Hue/Saturation/Luminance from the Colors menu. A thumbnail of the original image is shown on the left and a preview of the changes is shown on the right.
 

Sample with Decreased Luminence:

Sample with Increased Luminence:

Sample with Increased Hue:

Sample with Increased Saturation:

Sample with Decreased Saturation:
Grey Scale Function

When you convert an image to grey scale, the colors in the image are replaced with greys of equal luminance. Converting a 16 million color image to grey scale automatically reduces it to 256 colors. To convert the active image, select Grey Scale from the Colors Menu.

Basic Image Editing

Changing Image Width and Height
Rotation
Cropping
Cut and Paste
Enlarging an Image Canvas
Changing Image Width and Height

Resizing and resampling change an image's width and height. Resizing gives superior results with simple and hard-edged images with sixteen colors or less. Resampling gives superior results with photo-realistic images, and with images that are irregular or complex. Select Resize from the Image menu.


Original

Resized to 50%

Rotate/ Flip/ Mirror

Rotating spins an image by a specified number of degrees. Select Rotate from the Image menu. Select the direction of rotation. Select the degrees of rotation. Click OK. The Free option is only available for 256 color, grey scale and 16 million color images. To rotate an image of insufficient color depth, increase the image's color depth to 256 color, grey scale or 16 million color. Rotate it. Return the original color depth.

Flip spins an image on its top horizontal edge. Mirror spins an image on its side, vertical edge.


Rotate Right 90 and Left 90 degrees

Mirror Image

Flip Image
Cropping

Cropping an image eliminates unwanted parts of the original graphic. To crop an image, select the part of the image to retain. The area outside of the selection will be deleted. Select Crop button from Tool Palette, select the part of the picture you want to crop, then select Crop from the Image menu.


Cropped Image
Cut and Paste

Cut sends the selected portion to the clipboard and removes it from the image. The resulting "hole" is filled with the current background color. Select Cut from the Edit menu. Select Paste from the Edit menu to retrieve the contents of the clipboard As New Image, As New Selection, As Transparent Selection, or Into Selection.

Cut from original image.
Adjust an Image Canvas

Adjust an image canvas adds background color around the image, or below it or to the right or left. Select the background color. Select Canvas Size from the Image menu. Set the dimensions for New width and New height. Make sure both Radio buttons of Center image horizontally and Center image vertically are check. Click OK.

Original image on an enlarged canvas. 
(100 pixels square)

Using Selection Tools

Marquee Freehand Magic Wand

Selecting part of an image is the first step for many editing tasks. Selection areas can be moved, copied, deleted, edited, recolored and more.
 

Marquee

Use the Tool Options Palette (open Tool Options Palette from View -> ToolBars) to choose a rectangular, square, elliptical, or circular area. Click on the Select button in the Tool Palette. Use the Selection Type drop down box to choose the shape that you want to select. Click and drag the cursor around the area to select. To add more area to the selection, press and hold the <Shift> key. To remove area from the selection, press and hold the <Ctrl> key.

Freehand

Use the Freehand tool to select an irregular area. Click on the Freehand button in the tool palette. Hold down left button of the mouse and drag the cursor to draw the selection's boundary. The boundary can cross itself. The selection will be closed by adding a straight line between the selection's starting and ending points.

Magic Wand

Use the Magic Wand to select an area of a particular color, hue, or brightness. Click on the Magic Wand button in the tool palette.

Use the Match Mode drop down box from Tool Options Palette to choose a method for determining which pixels to select. Use the Tolerance spin control to determine how close the color of a pixel must be to the color of the chosen pixel in order to be selected. Use the Feather spin control to determine the sharpness of a selection's edges.

Painting and Drawing

Paintbrush Eraser Airbrush Flood Fill Clone Brush Text Tool

The Tool Palette contains a ten tools that simulate painting and drawing utensils. If some of the tools seem to do little, confirm that the video display and the image are both shown in 16 million colors. Once a tool is selected, a Style Bar for the tool will appear. The Style extention box determines how the color "leaves" the cursor. The Size spin control sets the pixel size for the tool. The Shape drop down box selects a tool shape. The Opacity spin control sets the tool's opacity. The Paper Texture drop down box selects a surface type. The paper texture setting determines how the image "absorbs" the color. To draw lines with a tool, press and hold the <Shift> key. Click at the end of a line segment.
Paintbrush

Select the colors to paint with. Click on the Paintbrush button in the tool palette. Position the cursor where you want to start painting.. Apply color to the image by moving the mouse. When finished painting, release the mouse button.

Eraser

The eraser works as an undo function. It is works on the last change to an image. Click on the Eraser button in the tool palette. Place the cursor, press and hold the primary mouse button(Left). Move the mouse to erase and then release the mouse button.

Airbrush

Select the colors. Click on the Airbrush button in the tool palette. Position the cursor and press and hold a mouse button to apply chosen colors. Opacity is an important style choice for this tool.

Flood Fill

The Fill tool fills an area with a color or pattern. Options control how it recognizes and replaces color. Click on the Fill button in the tool palette. Use the Fill Style drop down box to select the type of fill to perform. Every fill style except for the solid color fill has additional options.

Clone Brush

Use the Clone brush to copy part of an image to another location. Copy within an image, or between two images of the same color depth. Clone Mode controls the behavior of the source area when you stop copying and then resume copying somewhere else. In aligned mode, the source area behaves as if you never stopped copying. In non-aligned mode, the source area does not move and behaves as if you just selected it.

Click the Clone brush button in the tool palette. Position the cursor over the part of the image to copy. Click with the secondary mouse button. The computer will beep to indicate that the source area is selected. Click and hold the primary mouse button where you want to copy to. Move the mouse to copy color from the source area to the target area. When done copying, release the mouse button. To resume copying, hold the primary mouse button again, where the source area will be depends on the clone mode.

Text Tool

Click on the Text button in the tool palette. Click on the image where the text will place. A window of Text Entry appeals. Set the font properties. Click in the large text box labeled "Enter Text Here" and type the text. Select the Floating Checkbox option so the text will appear in the foreground color and will be a floating selection. Click OK. The text will be selected and can be moved by dragging its selection.

Layers

 
A layer is an individual level of an image. Until layers are merged, they remain independent and can be edited without affecting the rest of the layers. Use layers to add text or art to an image without altering the original.

Click the Layer button to open the layer palette window. The original image is the background layer. To create a new layer click the Add New Layer button  on the palette. 

Move between layers by clicking the name of the layer on the palette. Edit each layer making sure that the correct layer name appears on the title bar. Right click on the layer name in the palette to access individual layer Properties.

Hovering over a layer name brings up a thumbnail of the image on the layer. Individual layers can be deactivated and reactivated by clicking on the Layer Visibility Toggle,  or .


Changing Clipart Background to Transparent 
To make an object have a transparent background:

     1.   Bring clipart into Paintshop Pro.
     2.   Choose the background color.  Replace it with a color that is not used in the clip art.
     3.   Decrease color depth to 256.
     4.   Choose colors and edit palette.  Find the palette index number for the replacement color.
     5.   Choose colors and set palette transparency. 
     6.   Choose set color transparency to palette number and insert the correct index number.
     7.   Save as .gif file.
     8.   View with a web browser to see the transparency effect.

Copyright © 2003-2005, Drew University